Instalacja Nettemp na orangePi - debian

Funkcje dostępne w nettemp
raf
Posty: 59
Rejestracja: śr lut 15, 2017 9:33 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: raf » pt lut 17, 2017 3:54 pm

mam coś takiego:

[email protected]:~# ls -l /var/www
total 4
drwxr-xr-x 13 root root 4096 Feb 17 14:02 nettemp

raf
Posty: 59
Rejestracja: śr lut 15, 2017 9:33 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: raf » pt lut 17, 2017 3:58 pm

tak się zastanawiam może to coś z su nie tak ?

jak wpisuję:

[email protected]:~# sudo su
sudo: unable to resolve host OrangePI

jot
Posty: 892
Rejestracja: śr lut 03, 2016 8:50 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: jot » pt lut 17, 2017 4:17 pm

raf pisze:tak się zastanawiam może to coś z su nie tak ?

jak wpisuję:

[email protected]:~# sudo su
sudo: unable to resolve host OrangePI
Nie wiem, czy z 'su' jest coś nie tak, ale generalnie sudo/su to narzędzia, żeby po zalogowaniu się jako 'zwykły' użytkownik stać się SuperUżytkownikiem /coś jak użytkownik Administrator w Windows/.
W kawałku, który wkleiłeś masz znak # co zwykle oznacza bycie takim właśnie SuperUżytkownikiem.
Wklej wynik

Kod: Zaznacz cały

ls -l /var/www/nettemp

raf
Posty: 59
Rejestracja: śr lut 15, 2017 9:33 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: raf » pt lut 17, 2017 4:23 pm

wynik:


[email protected]:~# ls -l /var/www/nettemp
total 156
drwxr-xr-x 2 root root 4096 Feb 17 13:57 common
drwxr-xr-x 2 root root 4096 Feb 17 13:57 db
drwxr-xr-x 2 root root 4096 Feb 17 13:57 dbf
drwxr-xr-x 11 root root 4096 Feb 17 13:57 html
-rwxr-xr-x 1 root root 7557 Feb 17 13:57 index.php
drwxr-xr-x 19 root root 4096 Feb 17 13:57 install
-rw-r--r-- 1 root root 4315 Feb 17 14:16 install_log.txt
-rwxr-xr-x 1 root root 2134 Feb 17 13:57 install_nettemp
-rwxr-xr-x 1 root root 78568 Feb 17 13:57 map_example.jpg
drwxr-xr-x 5 root root 4096 Feb 17 13:57 media
drwxr-xr-x 24 root root 4096 Feb 17 13:57 modules
drwxr-xr-x 3 root root 4096 Feb 17 13:57 other
-rwxr-xr-x 1 root root 1828 Feb 17 13:57 readme.md
-rwxr-xr-x 1 root root 8808 Feb 17 13:57 receiver.php
drwxr-xr-x 2 root root 4096 Feb 17 13:57 status
drwxr-xr-x 10 root root 4096 Feb 17 14:03 wiringPi
[email protected]:~#

raf
Posty: 59
Rejestracja: śr lut 15, 2017 9:33 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: raf » pt lut 17, 2017 5:32 pm

tylko czy ja dobrą wersje instaluję ?

z tego co widzę to inni podczas instalacji mają inne wyniki po zainstalowaniu tzn więcej wyników:

[ ok ] packages
[ ok ] 1wire
[ ok ] DHT
[ ok ] GPIO
[ ok ] I2C
[ ok ] FW
[ ok ] SDM120
[ ok ] VPN
[ ok ] WWW
[ ok ] Cron

u mnie się kończy na I2C jak widać w powyższych postach

Awatar użytkownika
arTii
Betatester
Posty: 1639
Rejestracja: pt sty 22, 2016 8:40 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: arTii » pt lut 17, 2017 7:55 pm

pimowo pisze:A pokaż:

Kod: Zaznacz cały

ls -l /var/www
i jeszcze:

Kod: Zaznacz cały

cat /etc/lighttpd/lighttpd.conf |grep server.document-root
oraz

Kod: Zaznacz cały

 cat /etc/lighttpd/lighttpd.conf |grep index-file.names
Płytki A4 z soldermaską oraz G3 dostępne. Również inne części do NetTempa- jeśli ktoś potrzebuje - pisać śmiało... i zaglądać do działu Giełda

DOKUMENTACJA NetTemp w trakcie opracowywania
Pomoc online - kontaktuj się przez GG:14211

krkamil
Posty: 165
Rejestracja: śr gru 30, 2015 8:24 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: krkamil » pt lut 17, 2017 7:58 pm

Wpisz w przeglądarkę,
IPorange/nettemp/index.php

Powinna wyświetlić się strona statusu

techfreak
Site Admin
Posty: 4653
Rejestracja: sob mar 15, 2014 2:23 pm
Lokalizacja: Gdansk
Kontaktowanie:

Re: Instalacja Nettemp na orangePi - debian

Post autor: techfreak » pt lut 17, 2017 7:58 pm

Przyszło do mnie Orange pi zero będę też niedługo działać :)

jot
Posty: 892
Rejestracja: śr lut 03, 2016 8:50 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: jot » pt lut 17, 2017 8:04 pm

raf pisze:tylko czy ja dobrą wersje instaluję ?

z tego co widzę to inni podczas instalacji mają inne wyniki po zainstalowaniu tzn więcej wyników:

[ ok ] packages
[ ok ] 1wire
[ ok ] DHT
[ ok ] GPIO
[ ok ] I2C
[ ok ] FW
[ ok ] SDM120
[ ok ] VPN
[ ok ] WWW
[ ok ] Cron

u mnie się kończy na I2C jak widać w powyższych postach
Zainstalowałeś wersję stabilną. Generalnie "bezpieczną". Jest również wersja Beta z dosyć istotnymi zmianami i dodanymi funkcjonalnościami - ale jak nazwa wskazuje mogą, i występują, w niej występować błędy. Szczerze wątpię, żeby pomiędzy wersjami były dodawane jakieś zmiany pod kątem OrangePI, ale pewności nie mam.
Czy po instalacji zrestartowałeś urządzenie? Czy weryfikowałeś logi - log instalacji w kartotece Nettemp i pliki w /var/log, a w szczególności lighttpd/error.log pod kątem komunikatów o błędach? Przeglądałeś skrypty instalacyjne? Czy weryfikowałeś, że zmieniane przez instalator pliki konfiguracyjne są w tym samym miejscu co w Raspbianie?

raf
Posty: 59
Rejestracja: śr lut 15, 2017 9:33 pm

Re: Instalacja Nettemp na orangePi - debian

Post autor: raf » pt lut 17, 2017 8:05 pm

Oto wyniki:

[email protected]:/home/orangepi# ls -l /var/www
total 4
drwxr-xr-x 13 root root 4096 Feb 18 01:50 nettemp

–----------------

[email protected]:/home/orangepi# cat /etc/lighttpd/lighttpd.conf |grep server.document-root
cat: /etc/lighttpd/lighttpd.conf: No such file or directory

----------------------

[email protected]:/home/orangepi# cat /etc/lighttpd/lighttpd.conf |grep cat: /etc/lighttpd/lighttpd.conf: No such file or directory
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.

-----------------

[email protected]:/home/orangepi# cat /etc/lighttpd/lighttpd.conf |grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
cat: /etc/lighttpd/lighttpd.conf: No such file or directory

-----------------

[email protected]:/home/orangepi# server.document-root
server.document-root: command not found
[email protected]:/home/orangepi#


Wrzuciłem system lubuntu i jest identyczna sytuacja, wszystko się zainstalowało bez błędu.

Ale nettemp i tak się nie otwiera.


Wysłane z mojego LG-H850 przy użyciu Tapatalka

ODPOWIEDZ

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość