[METEO] Meteograf

Widgety tworzone przez użytkowników
wojmal
Posty: 321
Rejestracja: śr mar 02, 2016 12:14 pm

Re: [METEO] Meteograf

Post autor: wojmal » śr lut 15, 2017 8:37 pm

@jeicam sprawdź czy masz plik /var/www/nettemp/db/wireless_METEO6_press.sql.
Jeżeli plik jest to sprawdź czy nie ma pustych wpisów w bazie

Kod: Zaznacz cały

sqlite3 /var/www/nettemp/db/wireless_METEO6_press.sql "SELECT * FROM def"

Awatar użytkownika
pimowo
Betatester
Posty: 4313
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [METEO] Meteograf

Post autor: pimowo » śr lut 15, 2017 8:41 pm

Teraz to jest ip_metoid6_press.sql
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

jeicam
Posty: 19
Rejestracja: wt lis 24, 2015 10:04 pm

Re: [METEO] Meteograf

Post autor: jeicam » pt lut 17, 2017 2:58 pm

hej,

chyba jest plik...

Kod: Zaznacz cały

root@raspberry:/var/www/nettemp/db# clear
root@raspberry:/var/www/nettemp/db# sqlite3 /var/www/nettemp/db/wireless_METEO6_press.sql "SELECT * FROM def"
Error: no such table: def
root@raspberry:/var/www/nettemp/db# ls -al
total 4436
drwxrwsr-x  2 root     www-data   4096 Feb 17 14:55 .
drwxrwxr-x 14 root     www-data   4096 Feb 15 09:58 ..
-rwxrwsr-x  1 root     www-data      0 Feb 13 22:44 .gitignore
-rwxrwsr-x  1 root     www-data 582656 Feb 17 14:54 gpio_4_humid.sql
-rwxrwsr-x  1 root     www-data 576512 Feb 17 14:54 gpio_4_temp.sql
-rwxrwsr-x  1 root     www-data      0 Feb  5 23:07 gpio_stats_4.sql
-rw-r--r--  1 www-data www-data 190464 Feb 17 14:54 i2c_77_press.sql
-rw-r--r--  1 www-data www-data 188416 Feb 17 14:54 i2c_77_temp.sql
-rw-r--r--  1 www-data www-data      0 Feb 14 12:57 ip_meteoid20_gust.sql
-rw-r--r--  1 root     www-data      0 Feb 17 10:07 ip_meteoid6_press.sql
-rwxrwsr-x  1 root     www-data 742400 Feb 17 14:55 Raspberry_Pi.sql
-rwxrwxr-x  1 root     www-data   2576 Feb 17 14:55 Raspberry_Pi.sql-journal
-rwxrwsr-x  1 root     www-data 741376 Feb 17 14:54 system_cpu.sql
-rwxrwsr-x  1 root     www-data 729088 Feb 17 14:54 system_memory_cached.sql
-rwxrwsr-x  1 root     www-data 736256 Feb 17 14:54 system_memory.sql
-rwxrwxrwx  1 www-data www-data      0 Feb 14 13:17 wireless_METEO6_press.sql
-rwxrwxrwx  1 root     www-data      0 Feb 17 10:06 wireless_meteoid6_press.sql
root@raspberry:/var/www/nettemp/db#
Od kilku dni w smartfonach nie ma grafiki i nie maluje mi wykresów. w lapku w chromie jest ok. poza meteo.

Awatar użytkownika
slawko
Posty: 260
Rejestracja: czw lis 26, 2015 10:59 pm
Lokalizacja: Bełchatów

Re: [METEO] Meteograf

Post autor: slawko » śr mar 29, 2017 8:52 am

Wgrałem NetTempa na nowo i teraz Meteograf pokazuje tylko ciśnienie:
Obrazek
w samym NetTempie wszystkie czujniki z METEO@pimowo są odczytywane poprawnie, jak widać nawet godzina wschodu i zachodu się nie zgadza, co to może być, czas mam zsynchronizowany poprawnie.

Awatar użytkownika
pimowo
Betatester
Posty: 4313
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [METEO] Meteograf

Post autor: pimowo » wt kwie 25, 2017 3:00 pm

@slawko poradziłeś sobie z problemem?
Wygląda to tak jakby nie było danych...
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

Awatar użytkownika
slawko
Posty: 260
Rejestracja: czw lis 26, 2015 10:59 pm
Lokalizacja: Bełchatów

Re: [METEO] Meteograf

Post autor: slawko » wt kwie 25, 2017 4:39 pm

pimowo pisze:@slawko poradziłeś sobie z problemem?
Wygląda to tak jakby nie było danych...
Tak poradziłem sobie, mam odczyt z wszystkich czujników tylko godzina wschodu i zachodu się nie zgadza, prawdopodobnie muszę coś zmienić w kodzie.

Awatar użytkownika
pimowo
Betatester
Posty: 4313
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [METEO] Meteograf

Post autor: pimowo » wt kwie 25, 2017 7:36 pm

slawko pisze:Tak poradziłem sobie, mam odczyt z wszystkich czujników
Super, że działa ;)
slawko pisze:godzina wschodu i zachodu się nie zgadza, prawdopodobnie muszę coś zmienić w kodzie.
W kodzie trzeba ustawić współrzędne geograficzne gdzie mieszkasz.
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

Awatar użytkownika
slawko
Posty: 260
Rejestracja: czw lis 26, 2015 10:59 pm
Lokalizacja: Bełchatów

Re: [METEO] Meteograf

Post autor: slawko » wt kwie 25, 2017 8:10 pm

pimowo pisze:
W kodzie trzeba ustawić współrzędne geograficzne gdzie mieszkasz.
Mam ustawione swoje współrzędne, przekopiowalem kod z wersji która działała dłuższy czas bez problemu, ale nadal godziny wschodu i zachodu nie działają jak powinny, za chwilę sprawdzę jeszcze raz.

Awatar użytkownika
pimowo
Betatester
Posty: 4313
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [METEO] Meteograf

Post autor: pimowo » wt kwie 25, 2017 8:23 pm

Tak teraz sobie na to patrzę i masz rację, że coś jest nie tak...
Godziny są (prawie) OK, prawie bo jest inna strefa czasowa czyli trzeba w widgecie ustawić strefę czasową (czas letni/zimowy) ale nie wiem jak to zrobić tu musiałby pomóc Kolega @wojmal
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

Awatar użytkownika
slawko
Posty: 260
Rejestracja: czw lis 26, 2015 10:59 pm
Lokalizacja: Bełchatów

Re: [METEO] Meteograf

Post autor: slawko » wt kwie 25, 2017 8:29 pm

pimowo pisze:Tak teraz sobie na to patrzę i masz rację, że coś jest nie tak...
Godziny są (prawie) OK, prawie bo jest inna strefa czasowa czyli trzeba w widgecie ustawić strefę czasową (czas letni/zimowy) ale nie wiem jak to zrobić tu musiałby pomóc Kolega @wojmal
Tak @pimowo to jest. Właśnie szukam w kodzie co zmienić, ale na razie nic nie widzę .Kolega @wojmal na pewno wie co jest grane, więc poczekam aby coś nie namieszać.

ODPOWIEDZ

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 3 gości