[DIY] Stacja METEO

Użytkownicy tworzą, zmieniają.
ryba_ns
Posty: 130
Rejestracja: sob gru 24, 2016 2:31 pm
Lokalizacja: Nowa Sarzyna

Re: [DIY] Stacja METEO

Post autor: ryba_ns » sob sty 26, 2019 11:56 pm

z przykrością muszę stwierdzić ze nie działa... esp zgłasza się w putty :

METEO Weather Station
projekt by team nettemp.pl

ale nie usypia się ( patrzac na pingi ) i nie wysyła danych do nettempa...

bez wpisów rssi działa bez problemu....
Pozdrawiam Wojtek

[email protected], WeatherStation [email protected], Raspberry Pi 2B

Awatar użytkownika
pimowo
Betatester
Posty: 4920
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [DIY] Stacja METEO

Post autor: pimowo » ndz sty 27, 2019 1:00 am

OK, jutro spróbuję u siebie na żywym organizmie.

A czy to w ogóle działa?

Kod: Zaznacz cały

RSSI=wifi.sta.getrssi()
print("RSSI is", RSSI)
[email protected] HP MicroServer N54L, Raspberry Pi 3B, Raspberry Pi B+

ryba_ns
Posty: 130
Rejestracja: sob gru 24, 2016 2:31 pm
Lokalizacja: Nowa Sarzyna

Re: [DIY] Stacja METEO

Post autor: ryba_ns » ndz sty 27, 2019 11:19 am

Mmmmm chyba coś nie do końca działa...

Kod: Zaznacz cały

Sends data...
PANIC: unprotected error in call to Lua API (avr.lua:3: attempt to call field 'getrssi' (a nil value))
ObrazekObrazekObrazek

Wysłane z mojego HAMMER_AXE_M_LTE przy użyciu Tapatalka
Pozdrawiam Wojtek

[email protected], WeatherStation [email protected], Raspberry Pi 2B

ryba_ns
Posty: 130
Rejestracja: sob gru 24, 2016 2:31 pm
Lokalizacja: Nowa Sarzyna

Re: [DIY] Stacja METEO

Post autor: ryba_ns » ndz sty 27, 2019 3:17 pm

kombinowałem z tym rssi ale nic nie wykombinowałem :)

jedno co wykombinowałem to taki mały skrypt do programowania esp... umieszczamy w katalogu gdzie mamy

avr.lua config.lua esptool.py init.lua luatool.py netconfig.lua nodemcu_float_0.9.6-dev_20150704.bin

sudo su

twozymy plik skrypt

touch skrypt

dajemy mu prawa

chmod 755 skrypt

edytujemy

nano skrypt

i programujemy

Kod: Zaznacz cały

clear

echo ''
echo "wcisnij Enter by zaczac"
echo ''
read ff
clear

while true; do


echo ''
echo 'm - programowanie nodemcu_float_0.9.6-dev_20150704.bin'
echo "a - programowanie avr.lua "
echo "n - programowanie netconfig.lua "
echo "i - programowanie init.lua "
echo ''
echo "q - wyjscie "
echo ''

  read a

  if [ "$a" = "m" ]; then
echo ''
echo "wgrywam nodemcu_float_0.9.6-dev_20150704.bin"
echo ''
echo ''
python esptool.py -p /dev/ttyUSB1 write_flash 0x000000 nodemcu_float_0.9.6-dev_20150704.bin

  elif [ "$a" = "a" ]; then
echo ''
echo "wgrywam avr.lua"
echo ''
echo ''
./luatool.py -p /dev/ttyUSB1 -f avr.lua -t avr.lua

  elif [ "$a" = "n" ]; then
echo ''
echo "wgrywam netconfig.lua"
echo ''
echo ''
./luatool.py -p /dev/ttyUSB1 -f netconfig.lua -t netconfig.lua

  elif [ "$a" = "i" ]; then
echo ''
echo "wgrywam init.lua"
echo ''
echo ''
./luatool.py -p /dev/ttyUSB1 -f init.lua -t init.lua

elif [ "$a" = "q" ]; then
break

  fi

echo "Wpisałeś '$a'"
echo ''
echo ''
echo ''
echo "wcisnij ENTER by kontynulowac"

read dd

clear

done

clear
Pozdrawiam Wojtek

[email protected], WeatherStation [email protected], Raspberry Pi 2B

Awatar użytkownika
pimowo
Betatester
Posty: 4920
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [DIY] Stacja METEO

Post autor: pimowo » ndz sty 27, 2019 5:04 pm

ryba_ns pisze:Mmmmm chyba coś nie do końca działa...
Trzeba by było spróbować nowsze firmware bo możliwe, że w tym starym nie działa funkcja:

Kod: Zaznacz cały

wifi.sta.getrssi()
[email protected] HP MicroServer N54L, Raspberry Pi 3B, Raspberry Pi B+

ryba_ns
Posty: 130
Rejestracja: sob gru 24, 2016 2:31 pm
Lokalizacja: Nowa Sarzyna

Re: [DIY] Stacja METEO

Post autor: ryba_ns » ndz sty 27, 2019 8:02 pm

Masz na myśli nowsza wersje nodemcu_float …??

Wysłane z mojego HAMMER_AXE_M_LTE przy użyciu Tapatalka

Pozdrawiam Wojtek

[email protected], WeatherStation [email protected], Raspberry Pi 2B

Awatar użytkownika
pimowo
Betatester
Posty: 4920
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [DIY] Stacja METEO

Post autor: pimowo » ndz sty 27, 2019 8:14 pm

Tak.
[email protected] HP MicroServer N54L, Raspberry Pi 3B, Raspberry Pi B+

ryba_ns
Posty: 130
Rejestracja: sob gru 24, 2016 2:31 pm
Lokalizacja: Nowa Sarzyna

Re: [DIY] Stacja METEO

Post autor: ryba_ns » czw lut 07, 2019 11:27 am

Taka sytuacja .. od pewnego czasu zauważyłem taka sytuacje... Gdy akumulatory są ładowane i mają 100% wykres się nie pojawia.. przychodzi mi powiadomienie last update o braku aktualizacji danych...

Ktoś coś ?
ObrazekObrazek

Wysłane z mojego HAMMER_AXE_M_LTE przy użyciu Tapatalka

Pozdrawiam Wojtek

[email protected], WeatherStation [email protected], Raspberry Pi 2B

Awatar użytkownika
pasiekazj
Posty: 882
Rejestracja: pn wrz 28, 2015 10:35 am
Lokalizacja: Częstochowa
Kontakt:

Re: [DIY] Stacja METEO

Post autor: pasiekazj » czw lut 07, 2019 1:48 pm

Wejdź z settings, types i przestaw wartosć max przy battery np na 120 i sprawdź czy się poprawi.
Rpi 3 + SSD 240 GB + nettemp.
http://mmblog.pl

ryba_ns
Posty: 130
Rejestracja: sob gru 24, 2016 2:31 pm
Lokalizacja: Nowa Sarzyna

Re: [DIY] Stacja METEO

Post autor: ryba_ns » pt lut 08, 2019 9:30 am

pasiekazj pisze:
czw lut 07, 2019 1:48 pm
Wejdź z settings, types i przestaw wartosć max przy battery np na 120 i sprawdź czy się poprawi.
zmiana wartość max na ponad 100 pomogła, sek tkwił w tym ze wartość naładowania baterii dochodziła do 105%
Pozdrawiam Wojtek

[email protected], WeatherStation [email protected], Raspberry Pi 2B

ODPOWIEDZ