Znaleziono 15 wyników

autor: Daniel
wt cze 13, 2017 7:30 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO [problem]

Było w dyskusji przy odczycie wartości z różnych liczników:

Debouncing to jest czas w ms poniżej którego jak zarejestruje puls to go zignoruje. To jest taki softowy ogranicznik drgań stykow. Ja przy 1000 imp/kwh mam 90.

divider - dzielnik - ile impulsów przypada na kwh
autor: Daniel
śr cze 07, 2017 10:34 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO [problem]

po kilku miesiącach pracy na wersji stabilnej zainstalowałem betę i problem z dopisywaniem do bazy 1kWh co 1 min dalej występuje. Czy można to jakoś naprawić?
autor: Daniel
śr lut 08, 2017 6:23 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: [solved] licznik energii ELS SDM72D - GPIO [problem]

Jest prawie ok https://uploads.tapatalk-cdn.com/20170208/59b7c56bb99ff58e6534636537b428ba.jpg https://uploads.tapatalk-cdn.com/20170208/6323c486d739bfcd58c90806cb227af5.jpg NT co 1 minutę dodaje 1 kWh niezależnie od impulsów. Jednak w ALL sumują sie tylko impulsy. Dodatkowe kWh zapisują sie w bazie ...
autor: Daniel
śr lut 08, 2017 5:16 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

licznik energii ELS SDM72D - GPIO

Na wersji stabilnej licznik ładnie działa i idealnie liczy impulsy.

Jednak po zainstalowaniu bety 4.1.1 licznik liczy jeden impuls jako 1 kWh. Mimo ze w OFF Divider ustawiam 1000.

EDIT: wszystko działa!!
Pomogła czysta instalacja bety.
autor: Daniel
śr lut 01, 2017 8:27 am
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO

pimowo pisze:No to teraz test w malince i NT... zamiast licznika podłącz jakiś switch i klikaj impulsy ;)
Po testach nettemp nie zlicza impulsów.
Malina widzi zmianę stanu GPIO.
Testowałem na różnych GPIO.



Wysłane z iPhone za pomocą Tapatalk
autor: Daniel
wt sty 31, 2017 6:33 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO

pimowo pisze:No to teraz test w malince i NT... zamiast licznika podłącz jakiś switch i klikaj impulsy ;)
Zastosuje taki schemat.
Będe klikać kabelkami ;)
6829532700_1483714163.png
6829532700_1483714163.png (6.28 KiB) Przejrzano 814 razy
Dam znać wieczorem jakie wynik, pozmieniam GPIO.
autor: Daniel
wt sty 31, 2017 1:19 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO

Jak sprawdzić czy wyjście impulsowe jest sprawne ? Zaczynam wątpić czy licznik podaje impulsy. Zapewne najprościej oscyloskopem :) Ale tak naprawdę, to jak podasz zasilanie (ok. 3V) na to wejście, to wpięta w szereg dioda powinna mrugać co jakiś czas Dzięki ! Dioda ładnie miga - licznik sprawny. A ...
autor: Daniel
pn sty 30, 2017 10:59 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO

Jak sprawdzić czy wyjście impulsowe jest sprawne ?
Zaczynam wątpić czy licznik podaje impulsy.


Wysłane z iPhone za pomocą Tapatalk
autor: Daniel
wt sty 17, 2017 9:32 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO

Niestety nie udało mi się podłączyć licznika aby zliczał impulsy.
Próbowałem różnych modyfikacji i ustawień. Przeinstalowałem system. Zmieniłem maline za 3 na 2. Próbowałem na wersji stabilnej oraz beta.
Nie mam pomysłu co mogę jeszcze zrobić.
autor: Daniel
czw sty 12, 2017 8:16 pm
Forum: Nettemp wersja 4
Temat: licznik energii ELS SDM72D - GPIO [problem]
Odpowiedzi: 43
Odsłony: 4703

Re: licznik energii ELS SDM72D - GPIO

Zmieniałem GPIO bez rezultatu. NT nie znajduje czujnika.

odłączyłem czujnik i zwierałem przewody.
Przewody rozwarte:
GPIO271.png
Przewody zwarte:
gpio 27-0.png