[SOLVED] Znikający UPDATE

Awatar użytkownika
pimowo
Betatester
Posty: 4340
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [SOLVED] Znikający UPDATE

Post autor: pimowo » ndz lip 16, 2017 7:27 pm

Można i na pendrive :)
Ja jednak wolę żeby moja kopia była na innym sprzęcie. Tzn. NT na malinie, a kopia wszystkiego na NAS.
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

Miras
Posty: 5
Rejestracja: wt gru 06, 2016 11:55 am

Re: [SOLVED] Znikający UPDATE

Post autor: Miras » pn lip 17, 2017 5:49 pm

Ja to robię tak. Raz w miesiącu wyłączam malinę wyciągam kartę robię obraz 1:1 całej karty.
Około 15 minut roboty i zero stresu gdy coś pójdzie nie tak.

Awatar użytkownika
pimowo
Betatester
Posty: 4340
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [SOLVED] Znikający UPDATE

Post autor: pimowo » pn lip 17, 2017 6:41 pm

Miras pisze:Ja to robię tak. Raz w miesiącu wyłączam malinę wyciągam kartę robię obraz 1:1 całej karty.
Pomysł prawie OK... prawie bo raz w miesiącu masz piętnastominutową "dziurę" w odczytach :(
Miras pisze:Około 15 minut roboty i zero stresu gdy coś pójdzie nie tak.
\
Aż 15 minut roboty. Czy nie lepiej jak by to działało z automatu? :)

Jak będę miał trochę wolnego czasu to pomęczę programowy RAID 1 na dwóch pendrive + kopia zapasowa na zewnętrzne zasoby.
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

wicio1984
Posty: 7
Rejestracja: czw mar 23, 2017 10:08 pm

Re: [SOLVED] Znikający UPDATE

Post autor: wicio1984 » śr lip 19, 2017 7:59 am

Chyba moja malina Pi 2 będzie żyła.

Jak postawiłem system na pendrivie to po 2h myślałem że znowu mi padła bo strona mi się nie otwierała loguje się przez ssh a tu odpowiada powoli ale odpowiada, okazuje się że strony się otwierają ale około 1min, pendriva prędkość to 10MB/s. Po tygodniu męczenia się systemu kupiłem nowego i po testach jego pretkość to 30MB/s i momentalnie odżył strony się ładują a i wykorzystanie Ram i Cpu zmalało.
wykres memory na pendriwe.png
wykres cpu na pendriwe.png

Miras
Posty: 5
Rejestracja: wt gru 06, 2016 11:55 am

Re: [SOLVED] Znikający UPDATE

Post autor: Miras » śr lip 19, 2017 6:37 pm

pimowo pisze:
pn lip 17, 2017 6:41 pm
Miras pisze:Ja to robię tak. Raz w miesiącu wyłączam malinę wyciągam kartę robię obraz 1:1 całej karty.
Pomysł prawie OK... prawie bo raz w miesiącu masz piętnastominutową "dziurę" w odczytach :(
Miras pisze:Około 15 minut roboty i zero stresu gdy coś pójdzie nie tak.
\
Aż 15 minut roboty. Czy nie lepiej jak by to działało z automatu? :)

Jak będę miał trochę wolnego czasu to pomęczę programowy RAID 1 na dwóch pendrive + kopia zapasowa na zewnętrzne zasoby.
Z tym raz w miesiącu to trochę przesadziłem.
W tym roku to tylko: luty, kwiecień, i ostatni tydzień temu.

jot
Posty: 933
Rejestracja: śr lut 03, 2016 8:50 pm

Re: [SOLVED] Znikający UPDATE

Post autor: jot » śr lip 19, 2017 6:55 pm

W sumie nie uważam, żeby to jakieś istotne były te kopie całego systemu/karty. BO jeśli na RPi jest TYLKO NT to tak naprawdę w systemie plików nie zmienia się zawartość niczego poza /var/www (!!!). Więc na bardzo upartego wystarczy jeden obraz + kopia /var/www .
Ewentualnie można by obraz aktualizować po jakimś większym upgrade systemu, lub po rpi-update, ale jak by się dobrze zastanowić, to nie jest jakieś super konieczne..

Awatar użytkownika
pimowo
Betatester
Posty: 4340
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [SOLVED] Znikający UPDATE

Post autor: pimowo » śr lip 19, 2017 8:40 pm

@jot, ale tu chyba chodzi o to (tak mi się wydaje) że jeżeli padnie SD to w malinie podmieniamy kartę i "jedziemy" dalej :)
Dla mnie to też takie nie teges bo za mało automatyczne, no i "dziura" w odczytach :P
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

jot
Posty: 933
Rejestracja: śr lut 03, 2016 8:50 pm

Re: [SOLVED] Znikający UPDATE

Post autor: jot » śr lip 19, 2017 10:20 pm

@pimowo, ja to widzę tak:
1) instalujesz i konfigurujesz NT
2) robisz backup - obraz / kopia / cokolwiek
3) automat robi kopię /var/www -> w dowolnej częstotliwości
4) pada karta
5) odtwarzasz backup
6) odtwarzasz /var/www
7) restart

finisz,

a dziura w odczytach i tak będzie -> jak padnie karta, to jest dziura w odczytach

Awatar użytkownika
pimowo
Betatester
Posty: 4340
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [SOLVED] Znikający UPDATE

Post autor: pimowo » śr lip 19, 2017 10:30 pm

jot pisze: @pimowo, ja to widzę tak:
1) instalujesz i konfigurujesz NT
2) robisz backup - obraz / kopia / cokolwiek
3) automat robi kopię /var/www -> w dowolnej częstotliwości
4) pada karta
5) odtwarzasz backup
6) odtwarzasz /var/www
7) restart

finisz,
No i właśnie ja tak robię... W razie "W" mam dziurę w odczytach nie większą niż doba. Jakoś nie widzi mi się np. raz na miesiąc robić kopię i w razie "W" miesięczna dziura :(

Ja mam kopię: /etc, /root, /home/pi, /var/spool/sms, /var/www/nettemp Codzienna kopia i takich kopi mam 7 dni-nawet jak dziś coś namieszam to mam wszystkie wczorajsze pliki ;)
jot pisze:a dziura w odczytach i tak będzie > jak padnie karta, to jest dziura w odczytach
Zgadza się, ale chodzi o to, jak duża jest ta "dziura" ;)
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

Awatar użytkownika
pimowo
Betatester
Posty: 4340
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: [SOLVED] Znikający UPDATE

Post autor: pimowo » wt lip 25, 2017 9:31 pm

No i długo się nie nacieszyłem (dwa tygodnie?) swoim systemem na pendrive...
Malina przestała odpowiadać, a po podłączeniu pendrive pod laptopa "System plików wyłącznie do odczytu" :(
ehhh... coraz bardziej mam dość tych malinek... wrr...
Mój NetTemp mieszka w Raspberry Pi 3B na szynie DIN

ODPOWIEDZ

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość