Beta 4.1.20 DHT11 wartość 0.0

Awatar użytkownika
pimowo
Betatester
Posty: 4653
Rejestracja: czw lut 19, 2015 9:17 am
Lokalizacja: Wołów

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: pimowo » sob cze 09, 2018 6:36 pm

@krawcu, a dlaczego nie masz rezystora? Wszyscy dobrze wiedzą, że on być musi :)
[email protected] HP MicroServer N54L, Raspberry Pi 3B, Raspberry Pi B+

krawcu
Posty: 4
Rejestracja: pt cze 08, 2018 9:02 am

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: krawcu » czw sie 23, 2018 11:59 pm

Bez rezystora też przecież działa...
Niemniej dodałem 4kOhm pomiędzy 3V i Data. Podpoiłem pod GPRIO23 i nie wykrywa. Jak dodałem ręcznie GPIO23 i ustawiłem jako DHT22 to pokazuje w urządzaniach GPIO oraz jeden z wilgotnością i jeden z temperaturą. Na wykresach są wartości ale w statusach ich nie ma. CO może być powodem? Mam najnowszą wersję NT.

Awatar użytkownika
pasiekazj
Posty: 676
Rejestracja: pn wrz 28, 2015 10:35 am
Lokalizacja: Częstochowa
Kontakt:

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: pasiekazj » pt sie 24, 2018 6:24 am

krawcu pisze:
czw sie 23, 2018 11:59 pm
Bez rezystora też przecież działa...
Niemniej dodałem 4kOhm pomiędzy 3V i Data. Podpoiłem pod GPRIO23 i nie wykrywa. Jak dodałem ręcznie GPIO23 i ustawiłem jako DHT22 to pokazuje w urządzaniach GPIO oraz jeden z wilgotnością i jeden z temperaturą. Na wykresach są wartości ale w statusach ich nie ma. CO może być powodem? Mam najnowszą wersję NT.
Najnowsza to znaczy która dokładnie?
Rpi 3 + SSD 240 GB + nettemp.
http://mmsite.pl
Sprzedam:
SSD 120 GB - 100pln + KW

krawcu
Posty: 4
Rejestracja: pt cze 08, 2018 9:02 am

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: krawcu » pt sie 24, 2018 8:21 am

betamm 4.7.3 - aktualizowane wczoraj :)

Awatar użytkownika
pasiekazj
Posty: 676
Rejestracja: pn wrz 28, 2015 10:35 am
Lokalizacja: Częstochowa
Kontakt:

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: pasiekazj » pt sie 24, 2018 9:00 am

krawcu pisze:
pt sie 24, 2018 8:21 am
betamm 4.7.3 - aktualizowane wczoraj :)
Robiłem kiedyś poprawkę do tego i działało. MOżesz podesłac wejsciówkę ssh i www ?
Rpi 3 + SSD 240 GB + nettemp.
http://mmsite.pl
Sprzedam:
SSD 120 GB - 100pln + KW

Awatar użytkownika
pasiekazj
Posty: 676
Rejestracja: pn wrz 28, 2015 10:35 am
Lokalizacja: Częstochowa
Kontakt:

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: pasiekazj » pt sie 24, 2018 10:10 pm

Gotowe, poprawione, działa. Trzeba zrobić update i usunąć czujniki i ponownie dodać.
Rpi 3 + SSD 240 GB + nettemp.
http://mmsite.pl
Sprzedam:
SSD 120 GB - 100pln + KW

krawcu
Posty: 4
Rejestracja: pt cze 08, 2018 9:02 am

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: krawcu » pt sie 24, 2018 10:33 pm

A co było nie tak?

Awatar użytkownika
pasiekazj
Posty: 676
Rejestracja: pn wrz 28, 2015 10:35 am
Lokalizacja: Częstochowa
Kontakt:

Re: Beta 4.1.20 DHT11 wartość 0.0

Post autor: pasiekazj » sob sie 25, 2018 6:17 am

Moja wina. trzeba było kod poprawić.
Rpi 3 + SSD 240 GB + nettemp.
http://mmsite.pl
Sprzedam:
SSD 120 GB - 100pln + KW

ODPOWIEDZ